#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^---[\s\S]+?date: )\d{4}\/\d{2}\/\d{2}([\s\S]+?^---)"
Local $sString = "---" & @CRLF & _
"title: test" & @CRLF & _
"date: 2018/10/17" & @CRLF & _
"description: some thing" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"lorem ipsum ---" & @CRLF & _
"date: 2018/10/18" & @CRLF & _
"lorem ipsum" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"title: test" & @CRLF & _
"date: 2018/10/17" & @CRLF & _
"description: some thing" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"title: test" & @CRLF & _
"nodatehere:" & @CRLF & _
"description: some thing" & @CRLF & _
"---"
Local $sSubst = "$1replacement$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)