use strict;
my $str = '---
title: test
date: 2018/10/17
description: some thing
---
lorem ipsum ---
date: 2018/10/18
lorem ipsum
---
title: test
date: 2018/10/17
description: some thing
---
---
title: test
nodatehere:
description: some thing
---';
my $regex = qr/(^---[\s\S]+?date: )\d{4}\/\d{2}\/\d{2}([\s\S]+?^---)/mp;
my $subst = '$1replacement$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";