import Foundation
let pattern = #"(^---[\s\S]+?date: )\d{4}\/\d{2}\/\d{2}([\s\S]+?^---)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
---
title: test
date: 2018/10/17
description: some thing
---
lorem ipsum ---
date: 2018/10/18
lorem ipsum
---
title: test
date: 2018/10/17
description: some thing
---
---
title: test
nodatehere:
description: some thing
---
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1replacement$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)