// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^---[\s\S]+?date: )\d{4}\/\d{2}\/\d{2}([\s\S]+?^---)").unwrap();
let string = "---
title: test
date: 2018/10/17
description: some thing
---
lorem ipsum ---
date: 2018/10/18
lorem ipsum
---
title: test
date: 2018/10/17
description: some thing
---
---
title: test
nodatehere:
description: some thing
---";
let substitution = "$1replacement$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}