re = /(^---[\s\S]+?date: )\d{4}\/\d{2}\/\d{2}([\s\S]+?^---)/m
str = '---
title: test
date: 2018/10/17
description: some thing
---
lorem ipsum ---
date: 2018/10/18
lorem ipsum
---
title: test
date: 2018/10/17
description: some thing
---
---
title: test
nodatehere:
description: some thing
---'
subst = '$1replacement$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result