package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\w\d]{1,})(\s{0,}-\s{0,})([\w\d]{1,})(\s{1,}|(\s{0,}-\s{0,}))([\w\d]{1,})`)
var str = `NORMAND SKIMMER DSB-WHSPLT-0212R
NORMAND SKIMMER DSB-WHSPLT 0212
NORMAND SKIMMER DSB-WHSTPLT 0212
NORMAND SKIMMER DSB - WHSPLT 0212
NORMAND SKIMMER DSB - WHSPLT - 0212
NORMAND SKIMMER 0212
NORMAND SKIMMER 0212R
NORMAND SKIMMER
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}