import Foundation
let pattern = #"([\w\d]{1,})(\s{0,}-\s{0,})([\w\d]{1,})(\s{1,}|(\s{0,}-\s{0,}))([\w\d]{1,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
NORMAND SKIMMER DSB-WHSPLT-0212R
NORMAND SKIMMER DSB-WHSPLT 0212
NORMAND SKIMMER DSB-WHSTPLT 0212
NORMAND SKIMMER DSB - WHSPLT 0212
NORMAND SKIMMER DSB - WHSPLT - 0212
NORMAND SKIMMER 0212
NORMAND SKIMMER 0212R
NORMAND SKIMMER
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)