import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w\\d]{1,})(\\s{0,}-\\s{0,})([\\w\\d]{1,})(\\s{1,}|(\\s{0,}-\\s{0,}))([\\w\\d]{1,})";
final String string = "NORMAND SKIMMER DSB-WHSPLT-0212R\n"
+ "NORMAND SKIMMER DSB-WHSPLT 0212\n"
+ "NORMAND SKIMMER DSB-WHSTPLT 0212\n"
+ "NORMAND SKIMMER DSB - WHSPLT 0212\n"
+ "NORMAND SKIMMER DSB - WHSPLT - 0212\n"
+ "NORMAND SKIMMER 0212\n"
+ "NORMAND SKIMMER 0212R\n"
+ "NORMAND SKIMMER\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}