const regex = /\B\w+| +/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B\\w+| +', 'gmu')
const str = `89 562
John Smith
Γιάννης Παπαδόπουλος
Jean-François Dupuis`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);