// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)\B\w+| +").unwrap();
let string = "89 562
John Smith
Γιάννης Παπαδόπουλος
Jean-François Dupuis";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}