$re = '/\B\w+| +/mu';
$str = '89 562
John Smith
Γιάννης Παπαδόπουλος
Jean-François Dupuis';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;