#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\w+[@]+\w+[.]+[a-z]\w+"
Local $sString = "hhi@gmail.com" & @CRLF & _
"hello032@yahoo.com" & @CRLF & _
"12@a.com" & @CRLF & _
"a@a.com" & @CRLF & _
"Hello@gmail.com" & @CRLF & _
"12@12.com" & @CRLF & _
"12@gmail.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")