$re = '/\w+[@]+\w+[.]+[a-z]\w+/mi';
$str = 'hhi@gmail.com
hello032@yahoo.com
12@a.com
a@a.com
Hello@gmail.com
12@12.com
12@gmail.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);