re = /\w+[@]+\w+[.]+[a-z]\w+/mi
str = 'hhi@gmail.com
hello032@yahoo.com
12@a.com
a@a.com
Hello@gmail.com
12@12.com
12@gmail.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end