package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\w+[@]+\w+[.]+[a-z]\w+`)
var str = `hhi@gmail.com
hello032@yahoo.com
12@a.com
a@a.com
Hello@gmail.com
12@12.com
12@gmail.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}