import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+[@]+\\w+[.]+[a-z]\\w+";
final String string = "hhi@gmail.com\n"
+ "hello032@yahoo.com\n"
+ "12@a.com\n"
+ "a@a.com\n"
+ "Hello@gmail.com\n"
+ "12@12.com\n"
+ "12@gmail.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}