const regex = /\w+[@]+\w+[.]+[a-z]\w+/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+[@]+\\w+[.]+[a-z]\\w+', 'mgi')
const str = `hhi@gmail.com
hello032@yahoo.com
12@a.com
a@a.com
Hello@gmail.com
12@12.com
12@gmail.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}