using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+[@]+\w+[.]+[a-z]\w+";
string input = @"hhi@gmail.com
hello032@yahoo.com
12@a.com
a@a.com
Hello@gmail.com
12@12.com
12@gmail.com
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}