using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""([^""]*)""|'([^']*)'|(?:counter|attr|url)\(([^)]*)\))";
string input = @"counter(item)"" "" attr(data) "" counter(item1,decimal) url('test.jpeg') ""hi"" attr(xyz)
counter(name, style) "" "" invalid(data) url('test.jpeg') open-quote";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}