import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"([^\"]*)\"|'([^']*)'|(?:counter|attr|url)\\(([^)]*)\\))";
final String string = "counter(item)\" \" attr(data) \"\" counter(item1,decimal) url('test.jpeg') \"hi\" attr(xyz)\n"
+ "counter(name, style) \" \" invalid(data) url('test.jpeg') open-quote";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}