re = /(?:"([^"]*)"|'([^']*)'|(?:counter|attr|url)\(([^)]*)\))/m
str = 'counter(item)" " attr(data) "" counter(item1,decimal) url(\'test.jpeg\') "hi" attr(xyz)
counter(name, style) " " invalid(data) url(\'test.jpeg\') open-quote'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end