import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"status\\\":(?<status>[^\\}])\\\",\\\"requestId\\\":";
final String string = "{\"level\":\"debug\",\"message\":\"handler result : {\\\"body\\\":\\\"{\\\\\\\"numberOfProcessedRecords\\\\\\\":1}\\\",\\\"status\\\":201}\",\"requestId\":\"ecd06f97-975b-5faf-81a0-3431fb4d1070\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}