const regex = /\"status\":(?<status>[^\}])\",\"requestId\":/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"status\\":(?<status>[^\\}])\\",\\"requestId\\":', 'gm')
const str = `{"level":"debug","message":"handler result : {\\"body\\":\\"{\\\\\\"numberOfProcessedRecords\\\\\\":1}\\",\\"status\\":201}","requestId":"ecd06f97-975b-5faf-81a0-3431fb4d1070"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}