$re = '/\"status\":(?<status>[^\}])\",\"requestId\":/m';
$str = '{"level":"debug","message":"handler result : {\\"body\\":\\"{\\\\\\"numberOfProcessedRecords\\\\\\":1}\\",\\"status\\":201}","requestId":"ecd06f97-975b-5faf-81a0-3431fb4d1070"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);