use strict;
my $str = '{"level":"debug","message":"handler result : {\\"body\\":\\"{\\\\\\"numberOfProcessedRecords\\\\\\":1}\\",\\"status\\":201}","requestId":"ecd06f97-975b-5faf-81a0-3431fb4d1070"}';
my $regex = qr/\"status\":(?<status>[^\}])\",\"requestId\":/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}