re = /\"status\":(?<status>[^\}])\",\"requestId\":/m
str = '{"level":"debug","message":"handler result : {\\"body\\":\\"{\\\\\\"numberOfProcessedRecords\\\\\\":1}\\",\\"status\\":201}","requestId":"ecd06f97-975b-5faf-81a0-3431fb4d1070"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end