# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^(?:(""?)(.*?)\1(?:,|$)){2}.*$/$2/gm;t' <<< "\"0x00000000\",\"What do you want to eat? fish, meat or\n eggs?\",\"\"
\"0x00030002\",\"What do you want to eat?\",\"\"
0x00030002,What do you want to eat?,
"