use strict;
my $str = '"0x00000000","What do you want to eat? fish, meat or\\n eggs?",""
"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
';
my $regex = qr/(?m)^(?:(""?)(.*?)\1(?:,|$)){2}.*$/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";