import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(?:(\"\"?)(.*?)\\1(?:,|$)){2}.*$";
final String string = "\"0x00000000\",\"What do you want to eat? fish, meat or\\n eggs?\",\"\"\n"
+ "\"0x00030002\",\"What do you want to eat?\",\"\"\n"
+ "0x00030002,What do you want to eat?,\n";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}