$re = '/(?m)^(?:(""?)(.*?)\1(?:,|$)){2}.*$/m';
$str = '"0x00000000","What do you want to eat? fish, meat or\\n eggs?",""
"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;