#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?m)^(?:(""?)(.*?)\1(?:,|$)){2}.*$"
Local $sString = ""0x00000000","What do you want to eat? fish, meat or\n eggs?",""" & @CRLF & _
""0x00030002","What do you want to eat?",""" & @CRLF & _
"0x00030002,What do you want to eat?," & @CRLF & _
""
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)