using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(?:(""?)(.*?)\1(?:,|$)){2}.*$";
string substitution = @"$2";
string input = @"""0x00000000"",""What do you want to eat? fish, meat or\n eggs?"",""
""0x00030002"",""What do you want to eat?"",""
0x00030002,What do you want to eat?,
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}