const regex = new RegExp('(?m)^(?:(""?)(.*?)\\1(?:,|$)){2}.*$', 'gm')
const str = `"0x00000000","What do you want to eat? fish, meat or\\n eggs?",""
"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);