#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\[@Title]), ([^,)]+)"
Local $sString = "IF(SEARCH(LEFT([@Title], 3), "CMO") , "Marketing", " & @CRLF & _
"IF(SEARCH(LEFT([@Title], 3), "CIO") , "IT", " & @CRLF & _
"IF(SEARCH(LEFT([@Title], 3), "CTO") , "IT", " & @CRLF & _
"IF(SEARCH(LEFT([@Title], 3), "CRO") , "Sales", " & @CRLF & _
"IF(SEARCH(LEFT([@Title], 3), "CPO") , "Product", " & @CRLF & _
"IF(SEARCH(LEFT([@Title], 3), "COO") , "Operations", " & @CRLF & _
"IF(SEARCH(LEFT([@Title], 3), "CFO") , "Finance", " & @CRLF & _
"IF(SEARCH(LEFT([@Title], 3), "CEO") , "Exective", " & @CRLF & _
"IF(SEARCH([@Title], "President") , "Exective", " & @CRLF & _
"IF(SEARCH([@Title], "Chairman") , "Exective", " & @CRLF & _
"IF(SEARCH([@Title], "Social"), "Social" , " & @CRLF & _
"IF(SEARCH([@Title], "Content"), "Content" , " & @CRLF & _
"IF(SEARCH([@Title], "Blog"), "Blog" , " & @CRLF & _
"IF(SEARCH([@Title], "Digital"), "Digital" , "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")