// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[@Title]), ([^,)]+)").unwrap();
let string = "IF(SEARCH(LEFT([@Title], 3), \"CMO\") , \"Marketing\",
IF(SEARCH(LEFT([@Title], 3), \"CIO\") , \"IT\",
IF(SEARCH(LEFT([@Title], 3), \"CTO\") , \"IT\",
IF(SEARCH(LEFT([@Title], 3), \"CRO\") , \"Sales\",
IF(SEARCH(LEFT([@Title], 3), \"CPO\") , \"Product\",
IF(SEARCH(LEFT([@Title], 3), \"COO\") , \"Operations\",
IF(SEARCH(LEFT([@Title], 3), \"CFO\") , \"Finance\",
IF(SEARCH(LEFT([@Title], 3), \"CEO\") , \"Exective\",
IF(SEARCH([@Title], \"President\") , \"Exective\",
IF(SEARCH([@Title], \"Chairman\") , \"Exective\",
IF(SEARCH([@Title], \"Social\"), \"Social\" ,
IF(SEARCH([@Title], \"Content\"), \"Content\" ,
IF(SEARCH([@Title], \"Blog\"), \"Blog\" ,
IF(SEARCH([@Title], \"Digital\"), \"Digital\" , ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}