import re
regex = re.compile(r"(\[@Title]), ([^,)]+)")
test_str = ("IF(SEARCH(LEFT([@Title], 3), \"CMO\") , \"Marketing\", \n"
"IF(SEARCH(LEFT([@Title], 3), \"CIO\") , \"IT\", \n"
"IF(SEARCH(LEFT([@Title], 3), \"CTO\") , \"IT\", \n"
"IF(SEARCH(LEFT([@Title], 3), \"CRO\") , \"Sales\", \n"
"IF(SEARCH(LEFT([@Title], 3), \"CPO\") , \"Product\", \n"
"IF(SEARCH(LEFT([@Title], 3), \"COO\") , \"Operations\", \n"
"IF(SEARCH(LEFT([@Title], 3), \"CFO\") , \"Finance\", \n"
"IF(SEARCH(LEFT([@Title], 3), \"CEO\") , \"Exective\", \n"
"IF(SEARCH([@Title], \"President\") , \"Exective\", \n"
"IF(SEARCH([@Title], \"Chairman\") , \"Exective\", \n"
"IF(SEARCH([@Title], \"Social\"), \"Social\" , \n"
"IF(SEARCH([@Title], \"Content\"), \"Content\" , \n"
"IF(SEARCH([@Title], \"Blog\"), \"Blog\" , \n"
"IF(SEARCH([@Title], \"Digital\"), \"Digital\" , ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")