package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[@Title]), ([^,)]+)`)
var str = `IF(SEARCH(LEFT([@Title], 3), "CMO") , "Marketing",
IF(SEARCH(LEFT([@Title], 3), "CIO") , "IT",
IF(SEARCH(LEFT([@Title], 3), "CTO") , "IT",
IF(SEARCH(LEFT([@Title], 3), "CRO") , "Sales",
IF(SEARCH(LEFT([@Title], 3), "CPO") , "Product",
IF(SEARCH(LEFT([@Title], 3), "COO") , "Operations",
IF(SEARCH(LEFT([@Title], 3), "CFO") , "Finance",
IF(SEARCH(LEFT([@Title], 3), "CEO") , "Exective",
IF(SEARCH([@Title], "President") , "Exective",
IF(SEARCH([@Title], "Chairman") , "Exective",
IF(SEARCH([@Title], "Social"), "Social" ,
IF(SEARCH([@Title], "Content"), "Content" ,
IF(SEARCH([@Title], "Blog"), "Blog" ,
IF(SEARCH([@Title], "Digital"), "Digital" , `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}