using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[@Title]), ([^,)]+)";
string input = @"IF(SEARCH(LEFT([@Title], 3), ""CMO"") , ""Marketing"",
IF(SEARCH(LEFT([@Title], 3), ""CIO"") , ""IT"",
IF(SEARCH(LEFT([@Title], 3), ""CTO"") , ""IT"",
IF(SEARCH(LEFT([@Title], 3), ""CRO"") , ""Sales"",
IF(SEARCH(LEFT([@Title], 3), ""CPO"") , ""Product"",
IF(SEARCH(LEFT([@Title], 3), ""COO"") , ""Operations"",
IF(SEARCH(LEFT([@Title], 3), ""CFO"") , ""Finance"",
IF(SEARCH(LEFT([@Title], 3), ""CEO"") , ""Exective"",
IF(SEARCH([@Title], ""President"") , ""Exective"",
IF(SEARCH([@Title], ""Chairman"") , ""Exective"",
IF(SEARCH([@Title], ""Social""), ""Social"" ,
IF(SEARCH([@Title], ""Content""), ""Content"" ,
IF(SEARCH([@Title], ""Blog""), ""Blog"" ,
IF(SEARCH([@Title], ""Digital""), ""Digital"" , ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}