import Foundation
let pattern = #"(\[@Title]), ([^,)]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
IF(SEARCH(LEFT([@Title], 3), "CMO") , "Marketing",
IF(SEARCH(LEFT([@Title], 3), "CIO") , "IT",
IF(SEARCH(LEFT([@Title], 3), "CTO") , "IT",
IF(SEARCH(LEFT([@Title], 3), "CRO") , "Sales",
IF(SEARCH(LEFT([@Title], 3), "CPO") , "Product",
IF(SEARCH(LEFT([@Title], 3), "COO") , "Operations",
IF(SEARCH(LEFT([@Title], 3), "CFO") , "Finance",
IF(SEARCH(LEFT([@Title], 3), "CEO") , "Exective",
IF(SEARCH([@Title], "President") , "Exective",
IF(SEARCH([@Title], "Chairman") , "Exective",
IF(SEARCH([@Title], "Social"), "Social" ,
IF(SEARCH([@Title], "Content"), "Content" ,
IF(SEARCH([@Title], "Blog"), "Blog" ,
IF(SEARCH([@Title], "Digital"), "Digital" ,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)