# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/simulate\(\w+, \{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+\}\);/userEvent.$1(screen.getByTestId("$2"))/gm;t' <<< " simulate(component, {
type: \"click\",
target: \"[data-test-id=filterMenu-owner]\",
});
simulate(component, {
type: \"click\",
target: \"[data-test-id=filterMenu-ownerUser]\",
});
simulate(filterMenuPopup, {
type: \"click\",
target: \"[data-test-id=filterMenu-author]\",
});
"