use strict;
my $str = ' simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-owner]",
});
simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-ownerUser]",
});
simulate(filterMenuPopup, {
type: "click",
target: "[data-test-id=filterMenu-author]",
});
';
my $regex = qr/simulate\(\w+, \{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+\}\);/mp;
my $subst = 'userEvent.$1(screen.getByTestId("$2"))';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";