using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"simulate\(\w+, \{\n\s+type: ""(\w+)"",\n\s+target: ""\[data-test-id=([\w-]+)\]"",\n\s+\}\);";
string substitution = @"userEvent.$1(screen.getByTestId(""$2""))";
string input = @" simulate(component, {
type: ""click"",
target: ""[data-test-id=filterMenu-owner]"",
});
simulate(component, {
type: ""click"",
target: ""[data-test-id=filterMenu-ownerUser]"",
});
simulate(filterMenuPopup, {
type: ""click"",
target: ""[data-test-id=filterMenu-author]"",
});
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}