// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)simulate\(\w+, \{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+\}\);"#).unwrap();
let string = " simulate(component, {
type: \"click\",
target: \"[data-test-id=filterMenu-owner]\",
});
simulate(component, {
type: \"click\",
target: \"[data-test-id=filterMenu-ownerUser]\",
});
simulate(filterMenuPopup, {
type: \"click\",
target: \"[data-test-id=filterMenu-author]\",
});
";
let substitution = "userEvent.$1(screen.getByTestId(\"$2\"))";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}