import Foundation
let pattern = #"simulate\(\w+, \{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+\}\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-owner]",
});
simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-ownerUser]",
});
simulate(filterMenuPopup, {
type: "click",
target: "[data-test-id=filterMenu-author]",
});
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"userEvent.$1(screen.getByTestId("$2"))"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)