const regex = /simulate\(\w+, \{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+\}\);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('simulate\\(\\w+, \\{\\n\\s+type: "(\\w+)",\\n\\s+target: "\\[data-test-id=([\\w-]+)\\]",\\n\\s+\\}\\);', 'gm')
const str = ` simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-owner]",
});
simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-ownerUser]",
});
simulate(filterMenuPopup, {
type: "click",
target: "[data-test-id=filterMenu-author]",
});
`;
const subst = `userEvent.$1(screen.getByTestId("$2"))`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);