#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*source: (?!213\.211\.162\.5[567])(([0-9]{1,3}\.){3})[0-9]{1,3}"
Local $sString = "source: 213.211.162.54" & @CRLF & _
"source: 213.211.162.55" & @CRLF & _
"source: 213.211.162.56" & @CRLF & _
"source: 213.211.162.57" & @CRLF & _
"source: 213.211.162.58" & @CRLF & _
"source: 213.211.162.59"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")