import Foundation
let pattern = #".*source: (?!213\.211\.162\.5[567])(([0-9]{1,3}\.){3})[0-9]{1,3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
source: 213.211.162.54
source: 213.211.162.55
source: 213.211.162.56
source: 213.211.162.57
source: 213.211.162.58
source: 213.211.162.59
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)