const regex = /.*source: (?!213\.211\.162\.5[567])(([0-9]{1,3}\.){3})[0-9]{1,3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*source: (?!213\\.211\\.162\\.5[567])(([0-9]{1,3}\\.){3})[0-9]{1,3}', 'g')
const str = `source: 213.211.162.54
source: 213.211.162.55
source: 213.211.162.56
source: 213.211.162.57
source: 213.211.162.58
source: 213.211.162.59`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}