re = /.*source: (?!213\.211\.162\.5[567])(([0-9]{1,3}\.){3})[0-9]{1,3}/
str = 'source: 213.211.162.54
source: 213.211.162.55
source: 213.211.162.56
source: 213.211.162.57
source: 213.211.162.58
source: 213.211.162.59'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end