using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*source: (?!213\.211\.162\.5[567])(([0-9]{1,3}\.){3})[0-9]{1,3}";
string input = @"source: 213.211.162.54
source: 213.211.162.55
source: 213.211.162.56
source: 213.211.162.57
source: 213.211.162.58
source: 213.211.162.59";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}